Firefox/Flash on FreeBSD

Configuration

by ross at 00:37:25 on April 11, 2017

Firefox

# pkg install firefox firefox-i18n

firefox-i18n contains localizations and is optional

Adobe Flashplayer

First install Linux binary compatibility.

Note: For some reason flashplayer cannot be installed via pkg, but the port works.

# pkg install nspluginwrapper

# cd /usr/ports/www/flashplayer
# make install clean

Activate plugins

Run as target (regular) user:

> nspluginwrapper -v -a -i

And that's it.

 

Comments
I don't think we need flash anymore as most of sites like dailymotion, youtube, metcafe, vimeo, etc now support html5.

For java we have icedtea plugin.
You can now have a clean FreeBSD installation without any Linux module.
-- mzs
Friday, June 12, 2015, 10:37:10
it worked in my laptop adding compat.linux.osrelease=2.6.32 because (2.6.18) gives me an error "FATAL: kernel too old"
-- ISAIAS
Wednesday, August 5, 2015, 1:21:41
Because it does not react to an application when you click on it? Click on firefox and will not open.
-- nex
Wednesday, December 21, 2016, 11:22:49